The SquirrelMail Change_passwd plugin, originally written by Thiago Melo de Paula, allows users to change his/her system password in /etc/passwd or /etc/shadow from SquirrelMail. This updated version includes the ability to change Active Directory and LDAP passwords.

History

Version 4.2f

Released on July 19, 2009
[ download ]    Requires: SquirrelMail 1.2.8, Compatibility plugin

  • Added support for poppassd
  • Changed default password changer to poppassd

Version 4.2e

Released on January 4, 2009
[ download ]    Requires: SquirrelMail 1.2.8, Compatibility plugin

  • Removed current password checking on SquirrelMail. The backend will now be the one doing it.

Version 4.2d

Released on November 15, 2008
[ download ]    Requires: SquirrelMail 1.2.8, Compatibility plugin

  • Removed SSL certificate requirement when changing password in Active Directory
  • Plugin translation problem has been fixed

Version 4.2c

Released on August 9, 2008
[ download ]    Requires: SquirrelMail 1.2.8, Compatibility plugin

  • Updated chpasswd.c code to eliminate compiler warnings

Version 4.2b

Released on May 23, 2008
[ download ]    Requires: SquirrelMail 1.2.8, Compatibility plugin

  • Reduced dependence on config.php
  • Chpasswd now updates the last password change date

Version 4.2

Released on May 17, 2008
[ download ]    Requires: SquirrelMail 1.2.8, Compatibility plugin

  • Updated to use Compatibility 2.x
  • Added option to change password from the login page
  • Added support for Active Directory password change
  • Added support for LDAP password change
More history on the SquirrelMail website

Howtos

Screenshots

SquirrelMail LoginLogin
SquirrelMail OptionsSquirrelMail Options
Change PasswordChange Password

Visit the forum to ask for help or to give a comment.

***
Posted on 5/19/2008 and last updated on 11/6/2009
Filed under SquirrelMail